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Welcome
IXGen is an add-on utility to Adobe FrameMaker that enables you to build
Frame indexes faster than you can in Frame alone. The core of IXGen’s
functionality is an editable list of markers. You can perform any Frame edit
function on this list, then apply the edited list to your source documents.

Arguably, IXGen’s widest use is in indexing. However, you can use IXGen to
build lists of any defined marker, paragraph type, or character type. You also
can build lists of instances of keywords.

WHAT WE’LL 
COVER

• Background information: a little history, what platforms IXGen works on

• How to acquire IXGen, space requirements, price, support, warranty

• How to access IXGen once it’s installed; how to access IXGen help

• The Basic Stuff: how to use IXGen to build an editable list of index markers;
to create cross-indexed entries; to build lists of other types of markers

• Tips and tricks are scattered throughout

• Most of the techniques start on page 14

WHAT WE 
WON’T COVER

Cost analysis. There is, however, an excellent cost analysis section in the
whitepaper on IXGen at:

http://home.pacifier.com/~franks/ixmid.html

(Click the “cost analysis” link from this page.)
 Anne C. Barrett, Cisco Systems, Inc. 1



IXGen:  Tips, Tricks, and Techniques Background Info
Background Info
HISTORY IXGen was written and is currently marketed by FSA Tools (formerly Frank

Stearns Associates, Inc.). It first appeared in its current form in 1994.

I first used it during that year, quickly becoming addicted. Since that time I
wouldn’t be without it. (I’ve even refused a contract to index Frame documents
where IXGen wasn’t going to be available.)

PLATFORMS IXGen works only with Adobe FrameMaker. Currently, IXGen is sold in these
“flavors”:

• FrameMaker 6.0 on Windows (95, 98 and NT)

• FrameMaker 5.0/5.1 on Windows (95 and NT)

• FrameMaker 5.5 or 5.0/5.1 for SunOS

• FrameMaker 5.5/6.0 or 5.0/5.1 on Solaris

ACQUIRING 
IXGEN

You can access FSA on, and purchase IXGen through, their webpage:

http://home.pacifier.com/~franks/index.html

What you download from the page is an executable file. You’ll need a one-time
password to complete installation. FSA sends you this password when they
receive either a credit-card payment or a corporate purchase order number.

SPACE 
REQUIREMENTS

Total space required for IXGen works out to 1,238KB (1.2MB).
2  Anne C. Barrett, Cisco Systems, Inc.
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COST As of December 2000 IXGen was selling for:

SUPPORT Support is provided by the developer, Frank Sterns Associates, for one year
from the date of purchase.

WARRANTY Here’s a portion of the warranty statement found in the IXGen manual:

“This product has been thoroughly tested and will perform the functions
described in this manual. However, should you have a demonstrable problem
with the product we will ask for copies of the files that caused the problem, the
return of your original distribution, along with a brief statement from you
describing the problem.

Within 5 working days of receipt of your files we will verify the problem. We will
then, at our discretion, do one of the following: (a) immediately issue you a new
release of the product (no charge); (b) refund your purchase price (you must
return the materials); (c) resolve the problem within 60 calendar days and issue
you a revised version at NO CHARGE for either new materials or shipping.”

ACCESSING 
IXGEN AFTER 
INSTALLATION

Once installed, IXGen becomes an option in the Frame menu bar:

ACCESSING 
IXGEN HELP

IXGen documentation for all versions is available as a 749Kb PDF file from the
FSA webpage. There is no linked help from inside Frame.

Quantity
MS Windows

(Win 95/98, NT)
UNIX

(Solaris/SunOS)

1 $199.00 first copy $299.00 first copy

2-4 $149.00 each additional $179.00 each additional

5-9 $99.00 each additional $119.00 each additional

10+ $69.00 each additional $99.00 each additional
 Anne C. Barrett, Cisco Systems, Inc. 3
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Basic Usage
BUILDING A 
LIST OF 
EXISTING 
INDEX 
ENTRIES IN 
ONE FILE

As an indexer you’ll run across documents that have no indexes and documents
that have partial to full existing indexes. For starters, let’s work with a 200-page
zoo keepers’ manual that already has an index. Two of the index entries are:

To save you squinting, these entries are:

• bears, care and feeding;grizzly bears, care and feeding

• panda bears, care and feeding

The resulting index (containing just these entries) looks like this:

bears, care and feeding
grizzly bears, care and feeding
panda bears, care and feeding

We want it to look like this:

bears, care and feeding
grizzly bears

For Beginners:  The semicolon between “feeding”
and “grizzly” breaks the contents of this index marker
into two index entries.
4  Anne C. Barrett, Cisco Systems, Inc.
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panda bears

Exercise 1: Building and Using an IXGen List for One Frame File

Objective Build a list of existing markers, edit it, and reapply it to the file.

☺ Tip! Sometimes you’ll want to work with only a few index markers at a
time, such as those for a particularly difficult section. You can limit the
markers IXGen examines by highlighting a specific line, paragraph, or
section before generating the IXGen list.

Procedure 1 Select IXGen > Gen[erate] Editable Marker List.

The basic IXGen dialog appears:

Figure 1. Generate Editable Marker List dialog

The default marker in the Collect markers of type field is Index.

2 Click Generate.
 Anne C. Barrett, Cisco Systems, Inc. 5
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IXGen generates an IXGen list, which is in most functional respects the
same as a Frame table. For these index markers, the IXGen list looks like
this:

Figure 2. Portion of an IXGen list

3 Change this:

bears, care and feeding;grizzly bears, care and
feeding

to this (new text in bold):

bears, care and feeding;bears, care and
feeding:grizzly bears

4 Change this:

panda bears, care and feeding

to this:

bears, care and feeding:panda bears

5 In the IXGen list, select IXGen > Apply Edited Marker List...

The Apply Edited Marker List dialog appears:
6  Anne C. Barrett, Cisco Systems, Inc.
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Figure 3. Apply Edited Marker List dialog

6 Click Apply. IXGen applies your changes.

7 Your file has been altered with the refreshed index marker text. Save the
file.

8 Discard the IXGen file.

9 Regenerate your index.

☺ Tip! If you work with IXGen a lot you’ll find it’s useful to keep one index
entry in each marker.This is because the IXGen list is alphabetical, and
it’s easier to scan a list that contains a single entry per table cell. If you
habitually build index markers with multiple entries, don’t worry: you can
check the Split multiple index entries into separate markers checkbox
before you apply the list. (Remember that you can always pinpoint a
marker in your Frame file by using the Find function.)

However, if you intend to build page ranges in your index, leaving
multiple index entries in your markers until the last moment can give
you an advantage. See “Creating Page Ranges” on page 23 for why.

Outcome The index now looks like this:

bears, care and feeding
grizzly bears
panda bears
 Anne C. Barrett, Cisco Systems, Inc. 7
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ANATOMY OF 
AN IXGEN 
LIST

You may want to take a moment at this point and identify the parts of an IXGen
list.

The Usage Summary

The IXGen list comes with a usage summary or “quick start” at the top. This
section is a graphic in the template.

The Columns

The IXGen list has four columns. The “payload” area is the right column,
containing marker content that you can search, edit, and otherwise treat as text.
IXGen instructions and help refer to the cells in this column as “marker text
cells.”

All other columns contain the navigation information that tells IXGen where to
apply each marker.

! Caution: Do not alter the text in any but the right-most column. If you
change text in any of the navigation columns, IXGen will be unable to
apply that list. You’ll have to regenerate the list and redo your work.

Saving the List

You can discard an IXgen list as soon as you have successfully applied the
markers in it. However, it’s sometimes useful to save the list, particularly when
you’re doing a lot of changes (see the preceding caution) or must leave your
work for awhile. The saved IXGen file has an .fm extension. (I generally name
this file “ixxie” and overwrite it several times during a project.)

Deleting the List

IXGen generates a new list every time. If you do not discard your old lists, you
may eventually find yourself with a dozen or more open IXGen lists without a
clue as to which is the current one.
8  Anne C. Barrett, Cisco Systems, Inc.
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You can discard an unsaved IXGen list by doing either of the following:

• Exit without saving

• Press Ctrl-Alt while clicking the Discard List button at the top of the list.

Changing Fonts in the List

The default font for an IXGen list is Urbana. However, you can change the font
in the template. Changing the font in the template has zero effect on the font
used in your Frame file.

☺ Tip! If your system does not have Urbana installed, you may find that
IXGen appears not to work. Use this procedure to change fonts to
something that’s available on your system, such as Arial. (Thanks, Jan!)

To change the fonts

1 Open the file named edtblst.fm. The default install process placed it in your
Program\FrameMakerxx\Templates\Special directory.

2 Highlight the column(s) for which you want a different font. (Keep in mind
that you will be working only with the text in the far right column, so that’s
really the only one you must be able to read.)

3 Select Format > Paragraph.

4 Change the paragraph setup in that column to your preferred font.

5 Save and close the file.

ADDING 
MARKERS IN 
IXGEN

The index from Exercise 1 now looks like this:

bears, care and feeding
grizzly bears
panda bears

It would be good to have some cross-indexed entries in there. As luck would
have it, you can add these in IXGen.

Note: You cannot add markers by adding rows to the table. IXGen would not
have the necessary navigational information—that’s the info in the three
left-most columns—attached to your new text. However, you can use
the following procedure to introduce entries where entries already exist.
 Anne C. Barrett, Cisco Systems, Inc. 9
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Exercise 2: Adding New Markers To Old With IXGen

Objective Create new markers in the file by adding text to existing markers, using IXGen.

Procedure 1 Select IXGen > Gen[erate] Editable Marker List.

2 In the marker text cells, change the text as shown (new text is in bold):

bears, care and feeding;feeding and caring for bears

bears, care and feeding:grizzly bears;grizzly bears,
care and feeding;feeding and caring for
bears:grizzly

bears, care and feeding:panda bears;panda bears, care
and feeding;feeding and caring for bears:panda

3 In the IXGen list, select IXGen > Apply Edited Marker Text.

4 Make sure the Split multiple index entries into separate markers checkbox
is checked.

5 Click Apply.

6 Save your file.

7 Regenerate the index.

Outcome The index now looks like this:

bears, care and feeding
grizzly bears
panda bears

feeding and caring for bears
grizzly
panda

grizzly bears, care and feeding
panda bears, care and feeding

DELETING 
MARKERS IN 
IXGEN

There are two ways to do this. What you do depends on your needs.
10  Anne C. Barrett, Cisco Systems, Inc.
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Manually Deleting Markers

To delete a marker, delete the marker text cell for that marker. DO NOT delete
the navigational information for that marker from the columns to the left.

Use this method to delete multiple markers simultaneously.

☺ Tip! Particularly with some of IXGen’s advanced features (starting on
page 14 of this handout), when you’re re-indexing an entire document
it’s often faster to start by stripping out all existing markers and then
building the index again from scratch. To delete all the markers from a
file or book, delete the text from the right column of the entire table.
Leave the column itself empty but present.

Again, deleting any navigational information for those markers from the
columns to the left would amount to major bad news.

Automatically Deleting Duplicate Markers

Why You Would Want To Do This: Frame merges duplicate markers on the
same page, so having duplicates in the same area creates no problem for the
readers of hardcopy documents. In online documents, however, duplicate
entries create functional problems because a link can go to only one location.

In addition, every extra character creates overhead in your document.

Why You Would Not Want To Do This: Occasionally you’ll find that you’ve
created index entries with the same wording in different parts of the document.
While this often indicates poor document construction, in many cases further
differentiation may be possible (and would be useful to the reader). Before you
delete multiple markers, therefore, go through your index and see that there are
no unintended multiple page references.

How you do it:

1 Make your file or book file the active file.

2 Select IXGen > Delete Redundant Markers.

A simple Delete Redundant Markers dialog appears, giving you the choice
to “Go” or “Cancel.”

3 Click Go.
 Anne C. Barrett, Cisco Systems, Inc. 11
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IXGen will delete markers that are the same, leaving only one instance of
each.

BUILDING A 
LIST OF 
EXISTING 
INDEX 
ENTRIES IN A 
BOOK FILE

You can build an IXGen file for a book as easily as for a solitary file. However,
before you build an IXGen list for a book file you must alert IXGen to the files it
must examine.

Exercise 3: Creating an IXGen List for a Book

Objective Create an editable list of all marker entries in a book.

First-Time Setup for 
Multiple Files

1 In the book file, select IXGen > Select Files.

Make sure the Process Files window shows all text files in the document.
You can leave generated files like the Table of Contents and Index in the
Ignore window.

2 Click the Select Files button.

IXGen creates the .ixc file in the current directory.

Procedure 1 In the book file, select IXGen > Gen[erate] Editable Marker List.

The basic IXGen dialog appears (illustration on page 5).

2 Make your changes.

3 In the IXGen list, select IXGen > Apply Edited Marker List...

The Apply Edited Marker List dialog appears (illustration on page 7)

4 Click Apply.

5 Discard the IXGen file.

6 Regenerate your index.
12  Anne C. Barrett, Cisco Systems, Inc.
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Outcome Your files have been altered with the refreshed index marker text. Save the files
before proceeding.

For Beginners:  You can reduce your keystrokes
here by pressing Shift as you select File. This action
displays a slightly different menu than you would see if
you simply selected File. In this case, press Shift, then
select File > Save All Open Files.
 Anne C. Barrett, Cisco Systems, Inc. 13



IXGen:  Tips, Tricks, and Techniques Advanced Usage
Advanced Usage
CREATING 
MARKERS FROM 
KEYWORDS

Quite often a writer will give an indexer a list of terms that should be included in
a document. You can make quick work of this by using IXGen’s keyword
function.

1 Open <YourFrameMakerDirectory>\Templates\Special\keyctrl.fm.

1 Make a working copy of this file, or use it as a template for a new document.

2 List your keywords, one per cell, in the left-hand column of the table. Build a
new row for each keyword.

3 In the right-hand cell, list alternate phrases to use as the marker text. Put
each alternate in its own paragraph, but keep them in one cell. When IXGen
matches a keyword, it presents the list of choices for that keyword. You can
select one of those alternates or enter a new one.

Alternatively, leave the right-most cell blank. When this cell is blank, IXgen
uses the keyword itself for the marker text.

☺ Tip! To increase the number of possible alternates, change the value of
“MFKMaxHistory” in the fminit\ixgen.ini file (Windows only).

4 Save the file.

5 In your source file or book, select IXGen > Markers From Keywords.

Use the file browser that appears to select the keyword file. IXgen searches
through the source text for occurrences of the keywords. When IXGen finds
a keyword, select which alternate phrase to use for the marker, or enter new
14  Anne C. Barrett, Cisco Systems, Inc.
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text using the dialog box. Changes that you make to the Marker Text
Choices are automatically saved in the keyword document.

! Caution: A given keyword control file can be in use by only one user at
a time. If multiple users need simultaneous access to the same set of
keywords, make as many copies of the keyword control file as there are
simultaneous users. If each user independently changes the marker
text entries, each file will differ.

6 Save your text files.

If you did not supply alternate text in the right-hand cell, there’s still this fix:

1 Generate your index.

2 Lock your index (by pressing Esc-F l k).

3 Using live links, find each example and differentiate them for the index.

A REALLY FAST 
INDEXING 
TECHNIQUE

One of the fastest ways to build a new index for a technical document is to start
by building markers from defined paragraph tags, then add cross-indexing and
detail. Here’s one technique, start to finish.

Process overview:

1 At the book level, build markers for all warnings, cautions, figure captions,
and table captions (Exercise 4: “Building New Index Entries for Warnings
and Cautions,” starting on page 16, and Exercise 5: “Building New Index
Entries from Figure and Table Captions,” starting on page 19).

2 At the book level, build markers for all chapter and appendix titles (Exercise
5, starting on Exercise 6: “Building New Index Entries from Chapter Titles,”
starting on page 20).

3 At the file level, build markers for all Level 1, 2, 3, and 4 headers (Exercise
6, starting on Exercise 7: “Building New Index Entries from Headers,”
starting on page 20).

4 At the file level, go through and index other appropriate terms or concepts
that do not appear in the headers (Exercise 8: “Adding Detail To Your
Index,” starting on page 20).

5 At the file level, go through each index marker and create appropriate
groupings (Exercise 10: “Organizing Your Index Entries Into Hierarchies,”
starting on page 22).
 Anne C. Barrett, Cisco Systems, Inc. 15
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6 At the book level, proof, edit, and clean up your index for publication
(Exercise 7, starting on Exercise 12: “Proofing, Editing, and Cleaning Up the
Index,” starting on page 24).

For a 100-page document, the first three steps can take up to 30 minutes,
usually less. By far the most time-consuming activities are the last three.

☺ Tip! Before any index markers exist, the Create Markers from
Paragraph Tags is an excellent mechanism for checking and editing for
parallel construction among headings, figure captions, and so on.

Exercise 4: Building New Index Entries for Warnings and Cautions

Objective Build index markers from Warning and Caution paragraph tags and prepare
them for use in an index. This exercise is complex and so is presented in four
stages (A through D).

Assumptions: that your organization has defined paragraph tags that
approximate the ones used here as examples, and that you can make the
logical leap from example to reality.

Procedure A: Creating 
New Markers

Start with warnings and cautions.

1 In the book file, select IXGen > Markers From Para[graph] Tags.

The Create Markers from Paragraph Tags dialog appears:
16  Anne C. Barrett, Cisco Systems, Inc.
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Figure 4. Create Markers from Paragraph Tags dialog

Note: By default, you will create index markers. However, IXGen can create
markers from any defined marker type.

2 To keep things as visually clean as possible while you work, always handle
the item with fewer instances first. Technical documents seem to have more
cautions than warnings, so do the warnings first. In the Ignore Paragraphs
Tagged list, double-click your own paragraph tag for Warnings to place it in
the From Paragraphs Tagged list.

3 Click Create.

IXGen places a new marker at the beginning of every Warning paragraph.
For purposes of this discussion, let’s agree that your document has two
Warning paragraphs:

• “Warning: Do not attempt to pet the polar bear.”

• “Warning: Failure to follow proper feeding procedures may result injury
to both you and the bear.”

Procedure B: Editing the 
New Markers 

Each of the new markers contains all the text in its Warning paragraph. You
must edit these to fit your index style.
 Anne C. Barrett, Cisco Systems, Inc. 17
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1 Save your files.

2 Create an IXGen list of all editable markers.

3 Change this type of thing:

Warning: Never attempt to pet the polar bear.

to something like this:

polar bear, warning regarding contact

4 Change this type of thing:

Warning: Failure to follow proper feeding procedures
may result injury to both you and the bear.

to something like this:

feeding procedures, warning regarding

Note: The colons in the original text would, in fact, create a second
level in each of these index markers if left unedited.

5 In the IXGen list, select IXGen > Apply Edited Marker List...

The Apply Edited Marker List dialog appears (illustration on page 7)

6 Click Apply.

7 Discard the IXGen file.

Procedure C: Building the 
Next Set of Markers

1 Perform Procedure 4A with these changes:

• Return the Warning paragraph tag to the Ignore Paragraphs Tagged list.

• Move the Caution paragraph tag into the From Paragraphs Tagged list.

2 Perform Procedure 4B, using edits consistent with the “caution” wording.

☺ Tip! The generated IXGen list will contain both the edited Warning
markers you created in Procedures 4A and 4B, plus the new Caution
tags you just created. You’ll know which is which because the Warning
tags include the string “warning.”

Outcome Your draft index now has markers for all warnings and cautions. You might want
to save your files before proceeding.
18  Anne C. Barrett, Cisco Systems, Inc.
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Changing Capping in 
Created Marker Text

Your organization’s style may call for init-capping in captions. Many corporate
styleguides call for lowercasing all but proper nouns and acronyms. To quickly
adapt your draft index to that style, take advantage of IXGen’s Capitalization
facility:

1 In the IXGen list, select IXGen > Capitalization.

The Marker Text Capitalization dialog appears.

2 Of the choices provided, select all word in lowercase for Level 1 markers.
(All your markers at this point are Level 1 markers.)

3 Use Edit > Find/Change to recapitalize proper nouns and acronyms.

☺ Tip! You’ll be lowercasing things again in the next step, when you build
your markers for all the headings. If you wish, you could perform this
“decapitalization” step only once, later in the process. On the other
hand, I find the draft index more readable if I drop the capping at both
stages, and I do my recapitalizing only when the index is fairly well
along. Your call.

Exercise 5: Building New Index Entries from Figure and Table Captions

Objective Build index markers for the figures and tables in your document.

Procedure Proceed as through Exercise 4, using your paragraph tags for figure and table
captions.

Outcome ☺ Tip! Isolate your figure and table index entries in this early stage of
index development by preceding each one with the string “FIGURE” or
“TABLE,” as appropriate. This keeps them “out of the way”
alphabetically while you’re creating the rest of your initial markers.

Your draft index now has markers for all warnings, cautions, tables, figures, and
chapter/appendix headings.

You might want to save your files before proceeding.
 Anne C. Barrett, Cisco Systems, Inc. 19
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Exercise 6: Building New Index Entries from Chapter Titles

Objective Build one basic index entry from each chapter or appendix title.

Procedure Proceed as through Exercise 4, using your paragraph tags for chapter and
appendix headings.

Outcome Your draft index now has markers for all warnings, cautions, tables, figures, and
chapter/appendix headings.

You might want to save your files before proceeding.

Exercise 7: Building New Index Entries from Headers

Objective Build one basic index entry for each section header.

Procedure Build index markers from your headings, using the same process as in Exercise
4, Procedure A (page 16). Use your own paragraph tags for heading levels 1, 2,
3, and 4.

Note: Now is a good time to drop the capping, as described on page 19. Go
back and use Frame’s global Find > Replace options to capitalize all
proper nouns and acronyms.

Outcome Your draft index now has markers for all warnings, cautions, tables, figures,
chapter/appendix headings, and headers.

Again, you might want to save your files before proceeding.

Exercise 8: Adding Detail To Your Index

Objective You have now completed a fairly good draft index using IXGen, but the level of
detail is still quite coarse. Now is the time to go back through your text with an
imaginary magnifying glass, and examine it for other possible index entries in
the text.

Note: I often collaborate with the writer at this point to make sure I catch all
terms of importance. If you do this, you may wish to use the technique
described in “Creating Markers from Keywords” on page 14 to find key
terms.
20  Anne C. Barrett, Cisco Systems, Inc.
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Procedure At this stage build your index markers as you normally would in Frame.

Outcome You now should have a pretty good draft index!

Exercise 9: Adding Cross-Indexed Entries

Objective Now is a good time to cross-index. Enter your new index entries in the same
IXGen table cell as the old ones, with semicolons between each entry.

Procedure Start with a freshly generated IXGen list.

Because your material will differ, this section offers more in the way of example
than procedure. Suppose you have an entry that looks like this:

printing photographs in color

Change it to something like this (new text in bold):

printing photographs in color;photographs, printing
in color;color photographs, printing

This text will produce three index entries in a generated index:

color photographs, printing
.
.
.
printing photographs, printing
.
.
.
printing photographs

Continue this way through the IXGen list.

Outcome Your draft index now has entries for all warnings, cautions, tables, figures, and
headings for chapters, appendices, and sections, with cross-indexed entries.

You might want to save your files before proceeding.

For Beginners:  Cross-indexed entries (sometimes
called double-postings) are logical reversals of terms
in order to give the reader multiple access points. This
section contains one example.
 Anne C. Barrett, Cisco Systems, Inc. 21
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Exercise 10: Organizing Your Index Entries Into Hierarchies

Objective Now it’s time to organize all these first-level index entries into logical groupings
and hierarchies. This is a necessary but time-consuming step.

Procedure Here’s the way I do this:

1 Go to the top of the first text file.

2 Search for Markers of type Index.

3 Edit the text to match your index style. For example, change something like:

Making Courier Your Default Font

to something like:

courier, making the default font

Note: Be at peace: you clean up hierarchies (such as what you would
have with more than one reference to courier) a bit later.

4 Save the edited marker.

5 Highlight and copy the marker text.

6 Search for the next index marker.

7 If this index marker is at the same level as the last, repeat from Step 3.

If this index marker is for a document element that is subsidiary to the last
one your worked on, paste in your copied text. Add a colon to separate the
levels.

8 Continue this way through the document.

Note: This technique is fairly easy to follow down to your 3rd-level header.
You may, however, have to exercise some creativity to accommodate
levels below that. One way to do this is to delete the top-level header in
the marker, placing the greater amount of detail at the more-precise
lower levels.

Outcome Your draft document now has a fully formed index, although there are as yet no
page ranges or cross-indexed entries.
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Exercise 11: Creating Page Ranges

At last, we come to the section where you separate the entries within index
markers. This involves a little manual labor, but is worth it.

Objective Set up page ranges in your index.Procedure

Procedure 1 Generate a fresh IXGen list.

2 Add the string “<$startrange>” to the beginning of each marker that should
begin a page range.

☺ Tip! Add this only once to each text cell in the IXGen list. When you
split the entries into separate markers, IXGen will copy the
<$startrange> tag to the front of each new marker entry.

3 Apply the IXGen list to the file(s) without splitting multiple index entries into
separate markers.

Note: If you split them now, you’ll end up expending several times as
much effort as necessary.

4 Save your files.

This is where it things slow down again: in each file you must start at the top and
do repeated Find operations for Markers of Type > Index. For every marker that
starts with a <$startrange> tag:

1 Copy the tag and all the text.

2 At the end of the section, build a new marker by pasting the marker text into
the Marker dialog. Save the new marker.

This technique inserts a new marker in the same font as the current
paragraph.

3 In this new marker, change “<$startrange>” to “<$endrange>.”

4 When you are finished, generate a new IXGen list.

For Beginners:  In Frame you establish a page range
by using two markers: one at the start of the range,
one at the end of the range. The starting marker must
start with the string <$startrange>. The ending marker
must start with the string <$endrange>.
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5 Apply the list and this time check the box to split multiple index entries into
separate markers.

Outcome IXGen splits the entries in your markers into individual markers, copying the
<$startrange> and <$endrange> tags into each new marker.

Exercise 12: Proofing, Editing, and Cleaning Up the Index

Objective Proof, edit, and clean up your index for publication.

Procedure At the book level:

1 Generate an index.

2 Generate an IXGen file for the whole book.

☺ Tip! Put these files side by side on your screen. You can shrink the
IXGen file to show just the right-most column.

3 Working from your Frame index, go from front to back examining what
needs to change: misspellings, level errors, terminology, missing cross-
indexed entries... Make appropriate changes in your IXGen file.

4 Apply the IXGen file.

5 For every few changes in the IXGen file, regenerate the index to check the
effect of your changes.

☺ Tip! There will come a time quite early in this process when the IXGen
file will be very out of order in relationship to your index; for example, if
terminology changes or cross-indexing have added listings that are now
in order in the index but not in the IXGen file. When that happens, stop
where you are. Discard the IXGen file. Save your Frame files and
regenerate the IXGen file. Start again.

Outcome Your draft index should now be in pretty good shape. Discard the IXGen file.
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One More Thing
IXGen is a good tool for speeding the process in creating and editing an index.
Another thing I’ve used it for, however, is to dabble with a new kind of list for use
in technical documents, which I’ve called a procedures list. The purpose of the
list is to give an extremely condensed set of directions on all the procedures in a
document, which should be adequate for advanced users. At the same time, the
list provides access to further information through the referenced pages, which
accommodates less-experienced users. Here’s a section of one:

adding and removing monitored devices
(Step 1) open the Device List window 4-1
(Step 2) add and remove devices 4-1

Administration folder, opening and navigating
(Step 1) open the Monitor folder 1-5
(Step 2) open the Dashboard folder 1-5
(Step 3) display Administration folder files 1-5
purpose of this action 1-5

alerts, configuring
global settings for
(Step 1) open the Global Threshold Settings window 4-2
(Step 2) select the time interval between polls 4-2
(Step 3) enter maximum number of warnings or alerts 4-2
(Step 4) set logging of threshold violations 4-2
(Step 5) save the new settings 4-2

individual device settings, changing
(Step 1) open the Device Settings window 4-3
(Step 2) select the device to modify 4-3
(Step 3) select a time interval between polls 4-3
(Step 4) choose all or individual devices 4-3
(Step 5) save the new settings 4-3

In the procedures list the steps are listed in chronological, not alphabetical,
order. The procedure names are cross-indexed. The links are live when the
document is delivered in electronic form. It is in most respects simply another
index.

Here are the steps for creating such a list:
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1 In your file(s), create a new marker with a unique name. (“Procedure”
seems appropriate, so I’ll use it as an example.)

2 As you build your index, add Procedure markers at the location of
procedures and steps.

3 Make your “first-level header” here the name of the procedure.

4 Make each of the steps a second-level header. For example, the entry for a
step in adding and removing monitored devices might be:

adding and removing monitored devices:open the Device
List window

5 For each step, add the string “(Step #),” where # indicates the number of the
step.

adding and removing monitored devices:(Step 1) open
the Device List window

This will cause the list to sort in chronological, not alphabetical, order.

6 Build a new generated list of the type Index of Markers, using your
Procedure marker only.

7 Format the list as desired.

And that about wraps it up.
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The Speaker
Anne C. Barrett is a senior member of STC and a long-time technical writer and
indexer. She currently works at Cisco Systems, Inc., indexing all documentation
for one of Cisco’s business units. In her spare time she plays with wild bears.
Anne has no relationship with FSA Tools other than that of a satisfied customer.

Please e-mail Anne if you want a PDF or Frame version of this handout. You
can reach her at abarrett@cisco.com.
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