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Embedded Indexing 
Index entries that are inserted electronically into the computer files along with the text of the 
document are called “embedded.” Instead of creating a separate index file with dedicated 
indexing software, an embedded index is created in the same software as the rest of the document 
(e.g., Microsoft Word™ or FrameMaker®). Although embedded indexes have several 
advantages for the client, there are several disadvantages for the indexer who creates them. 

When clients ask for an estimate for an index that will be embedded in electronic text files, they 
are often dismayed at the time that it will take for such an index to be created. I often find myself 
explaining to the client why it takes longer to create an embedded index. Here are some of the 
advantages and disadvantages of embedded indexing – why clients want them and why they’re 
more of a challenge to create. 
Advantages 

Embedded indexing is usually desirable for computer-related manuals or other technical 
documentation that is likely to be updated often. When the manual is updated, the index can be 
re-generated quickly and the reference locators will be accurate. Another advantage is that if the 
document goes online, it’s fairly easy to make index references into links so the user can click on 
the index entry and the relevant text is displayed. Companies that publish “high-tech” books 
usually prefer embedded indexes; traditional publishers rarely request them. Some other 
advantages of embedded indexing are: 

• Indexing can begin before page numbers are finalized. If text is added or deleted, the 
locaters will still be accurate. 

• Future revisions of the text will not require re-indexing of the entire text since index 
entries will be retained in the text that remains unchanged. 

• Material that will be published in both a printed and electronic format will benefit from 
embedded indexing. 

• Embedded indexing is convenient for custom publishing (on-demand publishing); if a 
university press wants to create a textbook that just includes chapters 1, 3, 5, 7 and 9, the 
corresponding index can be generated quickly. 

• Embedded indexing is convenient for the author during editing of a book-length 
manuscript to find material quickly. 

Disadvantages 

Publishing programs like Microsoft Word and FrameMaker were not designed to be tools for 
indexing. As a technical writer, I’ve used FrameMaker to produce very large technical manuals. 
FrameMaker is well suited for this task because it was designed for that purpose. Companies who 
produce these desktop publishing programs have added other “bells and whistles” to their 
programs, but there have not been many improvements to the indexing feature in recent upgrades 
(Mulvany 1999).  

The major disadvantages of creating embedded indexes over stand-alone indexes are: 
• The indexer can't work on one set of text files while the author edits another set of files. 

Only one person can make changes to an electronic file at a time. 
• It takes much longer to write embedded indexes than stand-alone indexes. Mulvany 

estimates that creating indexes with DTP programs takes two to three times longer than 
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creating indexes with dedicated indexing software tools (1994, p. 259), and my 
experience supports that estimate. 

• Embedded entries will be deleted when text is deleted. Because the index entries are 
right in the text file, they will be deleted when the writer deletes the corresponding 
paragraph. When a document is extensively revised, how much of the original indexing 
work will remain? Do the remaining entries still make sense, or has the basic 
organization of the index been undermined? 

• The indexer must carefully check every cross-reference manually (dedicated indexing 
software does this for you). 

• Leading prepositions, articles and conjunctions in subentries aren't ignored, as they 
should be. This is a feature of most dedicated indexing programs. 

• The Indexer has little, if any, control over sorting. 

For the first part of this discussion, let's assume that the files are in Microsoft Word. In the latter 
part of this discussion, we’ll talk about the specifics of writing embedded indexes in 
FrameMaker. 
Indexing in Microsoft Word 

Every indexer has a different method and style of writing an index; indexing is an art. Because 
you cannot see the index develop in Word, some indexers use dedicated indexing software (like 
CINDEX™ or Macrex) to write the index and then re-type the entries into Word. This may save 
time because it’s easier to edit the index in the dedicated indexing software than it is to edit it in 
Word. You may find a method that is easier or faster for you, but the following is the basic 
procedure that I use when creating an index in Microsoft Word. 

Creating Index Entries 

In Word, an index entry that looks like this: 

software, installing, 59 

would be created by typing an index entry that looks like this: 

{xe "software, installing"} 

And index entries that looks like this: 

software 
copying, 38 
installing, 59 
searching, 71 
troubleshooting, 74 

would be created by typing index entries in the appropriate places in the body of the Microsoft 
Word file that look like this: 

{xe "software:copying"}{xe "software:installing"}{ xe "software:searching"}{xe 
"software:troubleshooting"} 

The index entries are actually hidden text in the file, so the index entries aren't visible on the 
screen unless you choose to display the paragraph markers and hidden text. (Click on the ¶ 
symbol in the top menu bar to Show/Hide ¶.) The dotted underline indicates that the text is 
hidden. 
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Since the index entries can really clutter up the text and make it difficult to read on the screen, I 
put the index entries at the end of each paragraph, as in the example below: 

To install the software, insert the CD into the CD drive.{xe "software, installing"}{xe 
"installing the software"} 

Of course, it is not necessary to type these strange-looking entries as I’ve shown them; you can 
use the Mark Index Entry dialog box that Word provides.  

From the Insert menu, choose Index and Tables; the following dialog box appears. Click to select 
the Type of index: Indented or Run-in. Then, select the Format for the index: Classic, Fancy, 
Modern, etc. Each of the different Formats will be shown in the Preview box to show the 
appearance of the index. 

 
Figure 1. Index and Tables dialog box 

Next, click on Mark Entry and type the Main Entry and Subentry in their respective boxes; click 
on Mark to have the index entry embedded in the Word file in hidden text. Repeat this process 
for each index entry. 

Another way to create an index entry with less typing is to select the text in the Word document. 
The selected text will be displayed in the Main Entry box of the Mark Index Entry dialog; then 
click on Mark to create the index entry embedded in the file. 

 
Figure 2. Mark Index Entry dialog box 

A third way to create an index entry, and the method that I find to be the easiest, is to use the 
Mark Index Entry dialog box to mark one index entry, and then copy and paste that entry in the 
Word file and edit it for all of the other index entries. I find that this goes much faster for me. 
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You can select the index entry by double-clicking on one of the curly brackets ({ }) that surround 
the index entry; then press Ctrl-C to copy and Ctrl-V to paste the new entry.  

To mark an index entry with a page range (for example: software, installing, 59-61), you must 
first define the range of text with a bookmark. Use the cursor to select the text from the 
beginning to the end of the topic in the Word file. Then, with the text selected on the screen, 
choose Bookmark from the Insert menu. The Bookmark dialog box appears: 

 
Figure 3. Defining a page range with a Bookmark 

Type in a name for the bookmark that is unique to that topic, such as “software_install” (spaces 
aren’t allowed) and click Add. Then return to the Mark Index Entry window (Insert → Index and 
Tables → Mark Entry), choose the Page Range Bookmark option and select the appropriate 
bookmark name for this topic range. 

 
Figure 4. Marking an Index Entry with a page range 

Word will insert an index entry in the text that looks like this: 

{XE “software:installing” \r “software_install” } 

The “\r” indicates that this index entry covers a page range that is defined by the bookmark 
“software_install.” 

Creating Cross-references 

To create a cross-reference, click on the Cross-reference Option in the Mark Index Entry box, 
and type the text after the “See” in the Cross-reference box. To create a cross-reference:  

finding, See searching 

The index entry will look like: 

{XE “finding” \t “See searching” } 
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The “\t” indicates that this entry is a cross-reference. If you want to create a “See also” cross-
reference, just type the word “also” after the “See” in the Cross-reference box. 

Formatting and Generating the Index 

Before generating the index, you must create a separate Word file and then create field codes in 
for the index in that file. (Field codes are commands, in hidden text, that tell Word how you want 
the index formatted.) I typically call my index file Index.doc. The field codes tell Word to search 
each file sequentially (chapter1.doc, chapter2.doc, chapter3.doc, appenda.doc, glossary.doc, etc.) 
for index markers before it generates the index.  

Following is a sample Index.doc with the field codes visible. The field codes are all of the text 
that is shown with a dotted underline.  

INDEX {Seq chapter \h \r9 \* Alphabetic} 

{RD chapter1.doc}{RD chapter2.doc}{RD chapter3.doc}{RD chapter4.doc}{RD 
appenda.doc}{RD glossary.doc} 

{INDEX \h “A” \!-z’ ‘\c “2” \s chapter} 

Note that the last line of codes {INDEX \h…} must be after the RD (Referenced Document) 
codes.  

This index with these field codes will produce an index with headings (A, B, C, etc.) between  
sections, and characters sorted from ! to z (special characters and symbols will be sorted before 
numbers and letters). The index will have 2-columns, and page references will include the 
chapter number as well as the page number, e.g., 1-4, 2-3, 3-6, etc. For more details on the 
various field codes that you can use for indexes in Microsoft Word, use the Help menu in Word 
to display Index topics. 

Since the generated index is actually a bunch of field codes, the index can be re-generated by 
pressing a key to update the index. On a PC, press F9 to update the fields. 

Editing an Index Entry 

After generating the index in Word, you will undoubtedly need to go back to edit some of the 
index entries. You must go back to each index entry in the text to edit it. Index entries are case-
sensitive in some versions of Word; this means that the two following entries could create two 
different index entries: 

{XE “Software, installing” } 
{XE “software, installing” } 

The index entries are not links like they are in FrameMaker, so you can’t click on them to display 
the appropriate index entry. But you can find index entries fairly easily by including “XE” in the 
search string. For example, to find one of the above index entries, I’d search for:  
“XE “software, installing””. 

Sorting Index Entries 

Microsoft Word alphabetizes word-by-word. Mulvany and the Chicago Manual of Style 
recommend that technical manuals be sorted letter-by-letter (in letter-by-letter sort, “database” 



Embedded Indexing 

  Peg Mauer, 2001 6  

would come before “data structure” which is how users would expect to find it). To override the 
sort order, use the following undocumented technique.1  

Use a semicolon after the index entry to specify how you want the entry to sort. Here are 
examples: 

{XE ".doc filename extension;doc filename extension"} 
{XE "filenames:8.3 naming convention;eightdotthree naming convention"} 

The special sorting string is included on the same hierarchical level as what you’re sorting. You 
only need to duplicate (with edits) the part of the entry that you want sorted differently. 

If you want to sort symbols in a special order, you have to invent a method that meets your needs. 
I use the @ symbol, and then I sort symbols in alphabetical order by author-chosen English 
name. For example: 

{XE "* (asterisk);@asterisk:wildcard character"} 
{XE "& (ampersand);@ampersand:logical AND operator"} 
{XE "| (vertical bar);@vertical:logical OR operator"} 
{XE ". (dot);@dot:filenames beginning with"} 
{XE ". (period);period" \t "See . (dot)"} 

 
& (ampersand) 
      logical AND operator 
* (asterisk) 
      wildcard character, 000 
. (dot) 
      filenames beginning with, 000 
. (period). See . (dot) 
| (vertical bar) 
     logical AND operator, 000 

 
It may not be easy, but at least it’s possible! 
This has been a brief overview of creating embedded indexes in Microsoft Word—a topic that 
covers 10 pages in the Microsoft Word User’s Guide. My intent has not been to show you all 
there is to know about creating embedded indexes in Microsoft Word but to give you an 
overview of how to create basic index entries with this tool.  
Indexing in FrameMaker 

The process for creating indexes in FrameMaker is similar, but different. For this discussion, I’ll 
assume that you are familiar with using FrameMaker, its commands, and its Reference Pages. 

There are products like IXgen™ that make it easier to create an index in FrameMaker, but for 
this discussion, we’ll just use the indexing feature that comes with FrameMaker. 

Creating Index Entries 

1. Open the FrameMaker document that you need to index. 

2. Place your cursor in the text where you want to create an index entry. I prefer to put index 
markers at the end of each paragraph because then they don’t clutter up the text. 

                                                      
1 Thanks to Seth Maislin for this section on sorting index entries in Microsoft Word. 
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3. Pull down the Special menu and choose Marker… The Marker box appears, with the default 
marker type of Index. 

4. Type the index entries for that paragraph in the Marker Text box, separating index entries 
with a semi-colon as shown in the illustration below. To create a subentry, separate the main 
entry and subentry with a colon. For example, “software:installing”.  
To enter an index entry that includes a page range, you must precede the index entry with the 
<$startrange> tag. At the end of the discussion (in a different index Marker box), the page 
range must end with a matching <$endrange> tag. For example, “<$startrange>installing the 
software” and “<$endrange>installing the software”. Make sure that the text which follows 
the <$startrange> and <$endrange> tags is identical. If there is an extra space or any other 
difference, the page range will not be created correctly. FrameMaker will assume that any text 
after the <$startrange> tag is part of the page range, so I always put them at the end of the 
Marker Text. You may have up to 255 characters in an Index Marker. 

5. Click on New Marker. 

 
Figure 5. Creating several index entries in a Marker dialog box 

Once you click on “New Marker” in the Marker box, FrameMaker creates an index marker in the 
text. If you choose to View ! Text Symbols, the index marker will be visible; it looks like a 
bold capital T. Note that the Marker box remains on the screen, but the “New Marker” button 
changes to “Edit Marker.” Since the index marker is still selected, you can make changes to the 
index entries that you just created and then click on “Edit Marker” for those changes to take 
effect. 

Creating Cross-references 

To create a cross-reference, precede the entry with the tag <$nopage>. For example, 
“<$nopage>finding. <Emphasis> See <Default Para Font>searching”. Note the initial capital 
letters in “Emphasis” and “Default Para Font.” These tags are case sensitive; if you type 
<emphasis> or <Default para font> the text will not format correctly. The <Emphasis> tag 
causes “See” to be in italics; the <Default Para Font> restores the font to what it was before you 
applied the italics. 

The <$nopage> tag will omit page references from any index entry that follows it in the Marker 
Text, so I always put the <$nopage> tag at the end of the index entry, as shown in the following 
example: 
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Figure 6. Creating a cross-reference in a Marker dialog box 

If you’re creating a cross-reference for an entry and you want the “See also” to follow the main 
entry 

like this: instead of being a subentry like this: 

problems. See also troubleshooting 
correcting, 33 
reporting, 34 

problems 
correcting, 33 
reporting, 34 
See also troubleshooting 

You must create the following index entries in FrameMaker:2 

problems. <Emphasis>See also <Default Para Font>troubleshooting:correcting 
problems. <Emphasis>See also <Default Para Font>troubleshooting:reporting 

Note that in this example, the <$nopage> tag is not required. 

Generating the Index 

Follow the previous steps to create index entries throughout the document. When you are ready 
to generate the index, do the following: 

1. Pull down the File menu and select Generate/Book… FrameMaker displays the 
Generate/Book window.  

2. Select the button for Standard Index, and click on Generate. FrameMaker will display the Set 
Up Standard Index box that is shown below. 

 
Figure 7. Generating the index 

                                                      
2 Thanks to Lynn Moncrief for sharing this helpful hint. 
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3. Check to make sure that the “Create Hypertext Links” box is checked, and click on Generate.  

FrameMaker will create the index and put it in a separate file. Now that you can see what your 
index entries look like, you’ll probably need to go back to edit some of them. Because you 
checked the box, “Create Hypertext Links,” FrameMaker created a link between your index 
entries and their associated text.  

Editing an Index Entry  

1. In the index document that FrameMaker just created, put the mouse pointer over the page 
number for the index entry that you need to edit.  

2. Hold down the Ctrl and Alt keys simultaneously, and click on the page number. FrameMaker 
will display the index marker for that index entry. 

3. Edit the index entry in the Marker Text box, and click on “Edit Marker.” You will have to 
generate the index again for the changes to be visible in the index. 

If you see index entries with page references of 2-?? or ??-7, it means that you didn’t specify the 
<$startrange> or <$endrange> tags correctly. In the index, you can return to the entry to correct 
this by holding down the Ctrl and Alt keys simultaneously, and clicking on the page number. 

Finding Index Markers 

While editing the index, you might want to search for index markers in the FrameMaker 
document. You can search for an index marker by using the Find/Change box. 

1. Check that the Marker window is displayed so you can see the index entries as you find them 
(choose Marker from the Special menu). 

2. Pull down the Edit menu and choose “Find/Change” (or press Ctrl F). 

3. Click on the down arrow that is next to the “Find Text:” field, and choose “Marker of Type:” 

4. Type “index” and press Enter. FrameMaker will find the next index marker and will display 
its contents in the Marker window. 

 
Figure 8. Finding index markers 

Deleting Index Markers 

You may occasionally want to delete all of the index entries in a FrameMaker document. 

1. Display the Find/Change box (choose Find/Change from the Edit menu). 

2. Choose “Marker of Type” and type “index” as the type of marker to find. 

3. Leave the “Change” field blank. 

4. Click “Change All In” to delete all index entries in the document3. 

Sorting Index Entries 

                                                      
3 Thanks to Karin Arrigoni for sharing this helpful hint. 
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By default, FrameMaker sorts index entries word-by-word. You can tell FrameMaker to sort 
letter-by-letter, by changing the Reference Page for the index. The following steps explain how 
to change the Reference Pages. 

1. Make sure that the window containing the index is the active window, and pull down the 
View menu; select Reference Pages.  

2. Find the Reference Page that ends in IX.  

3. Add a space to the beginning of the IgnoreCharsIX paragraph. 

4. Pull down the View menu and select Body Pages. 

5. Save the index document and re-generate the index to sort the index letter by letter. 

FrameMaker does not ignore prepositions, conjunctions and articles (and, in, with, for, a, an, the, 
etc.) in subentries. To ignore insignificant terms at the beginning of subentries, you must change 
the way FrameMaker sorts the subentries. 

FrameMaker will usually sort subentries in alphabetical order, as in the following example:  

errors 
in software 3 
reporting to technical support 2 

To force FrameMaker to ignore the word “in” in the subentry, type the following entries in the 
index Marker box: 

errors:reporting to technical support  
errors:in software[errors:software] 

The result will appear as follows:  

errors 
reporting to technical support 2 
in software 3 

Formatting the Index 

FrameMaker does not put a comma between the index entry and the page reference unless you 
tell it to. If you want a comma to precede the page reference, you must edit the Reference Page. 

1. When the index document is displayed in the active window, choose Reference Pages from 
the View menu. 

2. In the paragraph called SeparatorsIX, change the em space at the beginning of the line to a 
comma and a space. 

3. Pull down the View menu and select Body Pages. 

4. Save the index document and re-generate the index to see commas after the page references. 

FrameMaker will apply the same formats to the index that are applied to the source document. 
Here are some common formatting tips: 

To make a two-column index, choose Format ! Page Layout ! Column Layout; change the 
number of columns to two. 

Once you get an index formatted the way you want it, you can save that index and apply its 
format for future indexes (File ! Import ! Formats…). If changes are made to the document 
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after it is indexed, it can make a real mess of the index. If a paragraph is moved from one page to 
another, the <$startrange> tag might end up after the <$endrange> tag. This would cause the “?? 
errors” that I mentioned earlier under Editing an Index Entry. This is another reason why 
indexers should insist that the text and page numbers be final before they start indexing. 

Be sure to check each line of the index carefully before having it published! 
Good news! 

Fortunately, there are some products that make it easier to create and edit embedded indexes. 
When I write an index in Microsoft Word, I use the latest version of CINDEX (V 1.5), which 
allows me to drag and drop index entries from the CINDEX window into the Microsoft Word 
document in another window. This allows me to use CINDEX to write the index, sort it in page 
number order, and then drag and drop the entries into the Word file. This saves time because it’s 
so much faster to edit the file in dedicated indexing software than in Word. There are a couple of 
other companies who are currently working on other programs that will work similarly.  

For FrameMaker, IXgen is available from Frank Stearns Associates, Inc. (See 
www.pacifier.com/~franks/ixmid.html for more information.) IXgen allows you to do the 
following: 

• Gather some or all of your marker text in an alphabetized list, edit that list (using 
find/change, spell checker, and so on), then update the source markers. 

• Edit marker text while embedded in body text.  
• Collect text from selected paragraph tags (such as heads and subheads) or character tags 

(such as emphasis) and place that text in new markers.  
• Shuffle existing marker text to create new markers.  
• Search a document on a list of keywords and insert markers where those keywords were 

found. A keyword list, once made, could be used over and over again for new documents 
in similar topic areas.  

• Base a keyword list on an existing index.  
• Build hypertext links based on a keyword list.  

For now, all of the advantages of embedded indexing seem to lie with the client or manager who 
publishes the documents with embedded index entries in them. Indexers had to wait many years 
for computers and dedicated indexing software to make their jobs easier. Hopefully, we won’t 
have to wait so long for embedded indexing tools to be improved so that they meet the needs of 
their users. 
References 
CINDEX™ indexing software, Indexing Research, www.indexres.com  
FrameMaker is a trademark of Adobe Systems Incorporated, www.adobe.com 
IXgen, by Frank Stearns Associates. www.pacifier.com/~franks/ixmid.html  
Macrex indexing software, www.macrex.cix.co.uk/ 
Mulvany, Nancy C. (1994). Indexing Books, Chicago: University of Chicago Press 
Mulvany, Nancy C. (1999). “Software tools for indexing: revisited.” The Indexer 21 (4) Oct. 

1999, 160-63. 
 



Embedded Indexing 

  Peg Mauer, 2001 12  

Parts of this article were previously printed in KeyWords, (Jan/Feb 1998 and Sept/Oct 1998) and 
The Indexer, (April 2000).   
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